Suscríbete a mi blog y no te pierdas nada

Inicio > Blog > Prestashop 1.4 sigue siendo mejor que 1.5 y Prestashop lo sabe

Prestashop 1.4 sigue siendo mejor que 1.5 y Prestashop lo sabe

1 estrella2 estrellas3 estrellas4 estrellas5 estrellas (todavía no tiene votos)
Cargando…

El otro día hablaba con el amigo Jehyson de presteamshop.comy me comentaba que Prestashop está por sacar la versión 1.4.11

Recapitulando en versiones

Recapitulemos. Después de sacar la 1.4.9 y saltar a la 1.5, se fueron sucediendo las versiones con una de correcciones de la hostia, algunas de ellas llevaban 200 correcciones.

¿Cómo puedes meterle 200 correcciones a un software que lleva corriendo por ahí años y que tiene un equipo de programación enorme detrás con sede en París y Miami? Personalmente, no lo entiendo.

Total, la gente no actualizaba a 1.5. ¿Por qué? Coño, imagínate que tienes una tienda física y te dicen de renovar el local pero que puede que, durante la renovación, se joda la persiana y no se pueda abrir.
Adiós visitas. Adiós ventas.
Normal que no actualices.

Y Prestashop hizo un movimiento inteligente, pero que implicaba reconocer el error y envainársela. Sacar la versión 1.4.10.
¡Coño! No sacas una versión Major y cambias de número si no es mejor que la anterior.

Y si sacas esa Major, dejas de desarrollar sobre la versión anterior. ¡Si cambiaron todo el core! (el core es el corezoncito del Prestashop). Reestructuraron tablas de la base de datos, cambiaron llamadas del código smarty de las plantillas… Y patapim!
Volvemos para atrás y desarrollamos sobre la 1.4.9 para evolucionar a la 1.4.10.

Y ahora, la 1.4.11

Y ahora, unos meses después de sacar esa 1.4.10 ya se va diciendo por ahí que saldrá esa deseada 1.6, pero Prestashop anuncia que sacará también una evolución de la 1.4, la 1.4.11.

Manda cojones, pues ¡suerte que estamos a punto de sacar la segunda Major desde la 1.4! No entiendo el por qué. Ahora sí que no lo entiendo.

Ronda de preguntas

Me asaltan una serie de preguntas:
– ¿Es la 1.5 una “generación de desarrollo” declarada en vía muerta por el equipo de Prestashop?
– ¿Si no me puedo fiar de la 1.5, me tengo que fiar de la 1.6?
– ¿Habrán despedido al jefe del proyecto 1.5? ¡Yo lo hubiese hecho! Imagínate que uno de tus principales partners, Paypal, ve cómo sacas una Major y su módulo comienza a dar problemas y dejan de recibir ventas. ¡Uf!

Viva el Presta, manque pierda

Soy defensor a capa y espada de Prestashop, no me mal interpreten. Tiene sus cagadas como todo software y como todo software open source.

Lo que no me cabe en la cabeza es cómo un equipo de programación centrado solo en Prestashop puede generar tal número de errores, tantos como para volver a desarrollar sobre la versión anterior. Esperemos que estos chicos lo arreglen de cara a la 1.6.

Mientras tanto, seguiré recomendando quedarse en la rama 1.4, a menos que quieras estar con el culete torcido cada 2×3!

Publicado el 09.06.2013 en Prestashop
1 estrella2 estrellas3 estrellas4 estrellas5 estrellas (todavía no tiene votos)
Cargando…
Comentarios

29 comentarios para "Prestashop 1.4 sigue siendo mejor que 1.5 y Prestashop lo sabe"

  • El 09.06.2013 , Rafael Vargas ha comentado:

    Estoy en completo desacuerdo 🙂

    La versión 1.4.11.0 será lanzada para dar un soporte extendido con el menor coste posible. Prestashop es una empresa seria y como tal está haciendo lo correcto.

    Otra cosa es admitir que se precipitaron un poco al lanzar la rama 1.5 por la presión del mercado (la dichosa multi-tienda), pero a día de hoy encuentro la versión 1.5.4.1 con la estabilidad suficiente tras haber experimentado desde el día que salió hasta ahora. Aunque creo, como tú, que será una versión de paso (tratan de dar algo de compatibilidad con la 1.4, pero poca…).

    Sobre la versión 1.6, hasta donde tengo hablado con algunos componentes de Prestashop lo único que tienen pensado tocar la forma en la que funciona el front-office (con ideas de los temas multitienda y demás). Aparte de eso, el otro gran cambio es eliminar toda la compatibilidad hacia atrás con 1.4.

    Recapitulando: si no necesitas multi-tienda y eres tecnológicamente conservador: no utilices 1.5, pero luego no te quejes si es muy caro pasarse a la 1.6 🙂

    En otro orden de cosas: ¿escribirá test unitarios Prestashop algún día?

    • El 09.06.2013 , jordiob ha comentado:

      Pues discrepo sanamente. La de veces que me ha petado la 1.5 son la razón

  • El 09.06.2013 , Nicolás Viroga ha comentado:

    Totalmente de acuerdo contigo. La versión 1.5 de prestashop me tentaba solo por el nuevo panel de administración, pero con la cantidad de fallos he inestabilidad que tiene no cambio mi 1.4.9 de momento me quedare en esta versión hasta que se vea algo más claro y estable.

    Por cierto el último post de mi blog seguramente te interese. (Una alternativa a Zopim)

    • El 09.06.2013 , jordiob ha comentado:

      Gracias! Revisaré ese post 😉

  • El 09.06.2013 , Jan ha comentado:

    No entraré a valorar una y otra, cómo ingeniero de sistemas disfruté con NT 3.51, no volví a ver nada bueno hasta w2k, i menos hoy excepto el w7 x64 ent. El error es seguir al mercado que manda, y no escuchar a cliente y al desarrollador, pero en referencia a PrestaShop sigo recibiendo consultas sobre Prestashop y mariaDB, Skysql, postgresql e incluso Oracle. La historia del 1.5 de Prestashop es la misma que la de veritas backup exec 8.6 y 9.1, nos olvidamos de la 10 de la 10D de la 11 y sus variantes, y a la 12 R3 empezamos a pensar si valia la pena migrar de 2000 server a 2008 R2 porque el backup volvia a funcionar cómo 10 años antes. Por cierto alguien ha conseguido estabilizar una 1.4.9 o 1.4.10 sobre MySql 5.5 ?

    • El 09.06.2013 , jordiob ha comentado:

      Con la 1.5 lo dudo. No es estable ni sobre mysql

  • El 11.06.2013 , Monts ha comentado:

    Hola Jordi,
    Somos una empresa pequeñita aunque hacemos muchas cosas distintas. Estamos instalando la versión de prestashop 1.5.3.1. y tengo dudas acerca de la facturación y de la gestión del almacén.
    Tenemos tienda física y online y a su vez vendemos productos en italiano y en español (los productos son distintos).
    Creo que la forma correcta será abrir dos tiendas, una con los productos italianos y otra con los españoles, ambas gestionadas desde el mismo back office.
    Las preguntas son las siguientes:
    1. ¿Podemos mantener la misma numeración de facturas para las dos tiendas?
    2. Después, vendemos a la UE, pero también hacemos ventas extracomunitarias (sin IVA). Y me interesaría distinguir entre unas y otras teniendo dos series distintas. Una para las de la UE (de ambas tiendas) y otra para las extracomunitarias. ¿Sabéis si esto es posible? ¿Cómo?
    3. En cuanto a la gestión del almacén, ¿la tienda física cómo se la considera? ¿Cómo se disminuye el almacén de la tienda física en el momento en que hay una venta? No tengo claro si la tienda física debe crearse como un almacén o como una tienda.
    Muchas gracias.

  • El 12.06.2013 , Dolors ha comentado:

    Hola Jordi,

    te agradecería si me pudieras aconsejar:

    Tengo mi tienda en la versión 1.3.5 super estabilizada, con más de 1000 productos, más de 500 clientes y afortunadamente en pleno funcionamiento. Hace unas semanas me decidí a migrar a la 1.5.3. Sólo ver el nuevo modelo de datos me acordé de la familia de alguno. Al final vistos los comentarios de la peña y la velocidad de la versión, opte por quedarme con la versión 1.5.2. Ahora mismo tengo migrado el modelo de datos que no tiene mala pinta y me tengo que poner con los retoquillos del software.

    Aunque sinceramente leyendo tu post, ya no sé si continuar, pasarme a la 1.4.9 o esperarme a ver si lo reconducen. La verdad es que no tengo ninguna necesidad de cambiar de versión. Tú que harías en mi lugar?

    Muchas gracias y un saludo

    Dolors

    • El 12.06.2013 , jordiob ha comentado:

      Yo me iría de la 1.5.2 cagando leches. Tiene muuuuuchos errores

      • El 22.01.2014 , Dolors ha comentado:

        Hola Jordi,
        entonces para la migración te hice caso y no sabes como te lo agradezco porque todo fue de maravilla. Ahora quiero hacer otra tienda, pero esta será de nueva instalación y no sé si en medio año la rama 1.5 ha mejorado. Me puedes recomendar si utilizo la versión 1.4 o la 1.5? Muchas gracias y un saludo
        Dolors

  • El 14.06.2013 , Benjamin Utterback ha comentado:

    Hi Jordi,

    Thank you for the time to write this article. We always appreciate feedback. 1.4.11 will be released to optimize and further stabilize our many users who love v1.4. The upgrade will be seamless. We made no major changes to the 1.4 branch with version 1.4.11. These are not major updates or upgrades. We are simply taking the time to further better the software for the benefit of our users.

    As for v1.5, which you state in your post, it is a major technical change from 1.4. However, in a short time we have come to a version 1.5.4.1. There are more people updating their v1.4 store than ever before. We don’t force our users to upgrade and we never will. However, that does not mean that we forget about our users who choose to stay on v1.4. We cherish the opportunity to optimize our users’ stores. That is not to say we are perfect, there were initial difficulties with upgrades to 1.5 and we recognized that. Since then the upgrade process has drastically improved . We work hard day-in and day-out to provide the best possible Ecommerce solution.

    I invite anybody to download our latest version of the software. You’ll be happy that you did. We are proud of what we do and the countless people who we help. Thank you again for this post. If anybody has any questions about the software or Ecommerce in general, you are welcome to email us at contact@prestashop.com

    Benjamin Utterback
    Community Manager
    PrestaShop

    • El 14.06.2013 , jordiob ha comentado:

      Thanks Ben, appreciate your comment! Thanks a lot for the work and for improving 1.4’s branch. However, until 1.5.4.1, 1.5 wasn’t 100% operative, so we had to downgrade many sites to 1.4, which I think is a huge disadvantage and bad publicity for Presta.
      Anyway, thx for keeping on the good work! Looking forward for 1.6 release!

  • El 14.08.2013 , Luis ha comentado:

    Buenas Jordi, ya que hablamos de Prestashop 1.5 y sus inconvenientes, yo tengo una duda al respecto, estoy creando varias tiendas en prestashop 1.5.4.1, y tengo una duda respecto a las combinaciones de productos, estas combinaciones de productos, google las toma como productos distintos y me da metas duplicados o me las toma como el mismo producto?, yo creo que me lo toma como el mismo producto.

    La otra duda es que en los atributos da la opción de “utilice este atributo en la URL generada por el módulo de navegación por capas”, tu esta opción la habilitas?

    Gracias y Saludos.

    • El 14.08.2013 , jordiob ha comentado:

      Juraría que el mismo producto. El id y la url son iguales

  • El 19.08.2013 , Juan ha comentado:

    Hola Jordi:

    Soy nuevo en el tema del CMS bajo Prestashop. Estoy trabajando en el diseño de una tienda (En 1.5.4) y demás. El CSS no me da muchos problemas a la hora de diseñar. La mayor dificultad que tengo es identificar donde opera cada modulo para maquetar. Veo que existe una lista con los Hocks que indica qué modulos incluyen, pero hay casos en los que no sé donde mirar. Por ejemplo: Existe en mi tema una opción en la página de productos para compararlos. Quiero que no figure. Veo tpl de ‘comparationproducts’ o similar, pero no sé qué hacer para que no conste.
    ¿Algún truco para iniciar la maquetación de todo lo que no es CSS?

    Un Saludo

    • El 19.08.2013 , jordiob ha comentado:

      En este caso, desde preferencias, puedes desactivar el comparadador de prods. Lo mejor es seguir los consejos del foro y las guías y tutoriales hechos. Armarse de paciencia y darle caña 🙂

  • El 07.09.2013 , carlos ha comentado:

    por favor, al dia de hoy (07/09/2013) la version 1.5.5 es estable o me recomiendan la 1.4.11 ?
    gracias

    • El 07.09.2013 , jordiob ha comentado:

      1.4.11 mejor 🙂

  • El 13.11.2013 , erm3nda ha comentado:

    Yo ya hice me presentación en el foro Prestashop y de lo primero que dije fué “Paso de probar PS1.5 hasta que funcione bien”, cosa que visto lo visto no va a suceder.

    Hay ciertas cosas que de cara al administrador molan más en la versión 1.5, pero como el que compra es el que está en el front, pues 1.4 manda.

    Una gran cuestión la de “¿Si no me fío del a versión 1.5, me tengo que fiar de la 1.6?”
    Esto vuelve a ser tan fácil como NO usar la 1.6 hasta que la 1.7 exista y/o la 1.6 haya demostrado servir para algo. Soy muy afán de no usar en producción NADA nuevo, siempre una versión anterior y siempre que no hayan blogs que puedan hechar al soft por tierra con razones de peso.

    Saludos 😉

    • El 13.11.2013 , jordiob ha comentado:

      Pues no sé qué nos deparará la 1.6 la verdad, ojalá sea la repolla!

  • El 28.01.2014 , Carlos ha comentado:

    Hola Jordi, un placer leerte, de verdad

    ¿Que opinas de la 1.5.6.2? ¿Podemos fiarnos de esta versión?

    • El 28.01.2014 , jordiob ha comentado:

      Me fío! ^_^

      • El 02.02.2014 , Carlos ha comentado:

        Gracias! ¿La has probado en producción?

        Estoy trabajando en local con ella y parece estable pero después de leer este post, estoy aco****

        Salu2
        Carlos

        • El 02.02.2014 , jordiob ha comentado:

          1.5.6.2 es bien

          • El 02.02.2014 , Carlos ha comentado:

            Gracias….al ataque!

  • El 04.02.2014 , Carlos ha comentado:

    Perdon por escribirte aqui pero el formulario de contacto no funciona

    Te escribo para pedirte ayuda, estoy en local con una copia de mi web, en esta copia he realizado upgrade desde la 1.4.9.0 a la 1.5.6.2, he estado trabajando en local y puliendo detalles y el problema es que ahora no soy capaz de rescatar los últimos pedidos y clientes de la versión en producción (1.4.9.0) siempre me da error y no se como incorporarlos a la nueva.

    No se me ocurre que hacer, estoy posteando aquí : https://www.prestashop.com/forums/topic/304557-problema-con-importaci%C3%B3n-de-bases-de-datos-desde-1490-a-1562/

    ¿Se te ocurre algo?

    Gracias y perdón por usar este canal

  • El 03.05.2014 , miguel ha comentado:

    Carlos totalmente de acuerdo contigo, yo tenia la version 1.4.9 que iva de lujo y en que momento se me ocurrio actualizar la tinda que desde entonces todo son echarles horas al ordenata que no hay forma cuando no son pitos son flautas , un dia va bien y al siguiente ocurre algo ,que falla o funciona mal, artito artito me tiene , tras tu comentario compruebo que no soy el unico y me vuelvo a la 1.4.9. Posdata todo el tiempo que se pierde en solucionar estos errores se podria emplear en marketing y promocion ventas, asi no hay forma.

  • El 26.09.2015 , erm3nda ha comentado:

    La versión 1.4 volverá a armar revuelo, por la última actualización que supuestamente promete que funcionará con versiones modernas de PHP, como la 5.4 en adelante. Con la de tiendas que hay en 1.4 y lo mal que lo hacen los proveedores de hosting que cambian de PHP 5.3 a 5.4 sin opción a cambio, es cuestión de tiempo que empiecen a caer clientes y ofertas de migraciones 😀

Deja tu comentario

Acepto expresamente la política de privacidad de jordiob.com