Nov 052012

Primeras impresiones después de trabajar a fondo con Prestashop 1.5

Tweet about this on Twitter0Share on LinkedIn1Buffer this pageEmail this to someone

Si leéis este blog a menudo, sabréis que soy fan y defensor a muerte de Prestashop. Pero también soy crítico cuando toca, porque para eso estamos, para mejorar en la medida de lo posible esta gran solución de eCommerce que es pshop.

Después de un mes y pico trabajando con la nueva versión de Prestashop (la 1.5 y sucesivas versiones que han ido saliendo), puedo decir que paso más de trabajar con ella hasta que no arreglen una serie de cosas que petan más que una escopeta de feria.

Me he ido encontrando con cosas que fallan dentro del catálogo, incluso cuando estás trabajando en local.
Atributos que no se graban, fichas de producto que petan, imágenes de producto que no se borran, módulos que petan porque se han compatibilizado mal, Paypal que falla cada 2×3, plantillas que no se recompilan del todo… lo siento, pero así no se puede currar bien. Cuando lo arreglen me pondré manos a la obra, pero no antes.

Recordad, además, que muchas de las plantillas de pago que existen y muchísimos de los módulos gratuitos y de pago que hay NO son compatibles con la versión 1.5, por lo que no los podréis aprovechar hasta que sus desarrolladores no los actualicen.

Así que, ¿actualizar a Prestashop 1.5? No, amigos. Quédense con la versión 1.4.9 que es muy estable y funciona de periquete.

Tweet about this on Twitter0Share on LinkedIn1Buffer this pageEmail this to someone
1 estrella2 estrellas3 estrellas4 estrellas5 estrellas (todavía no tiene votos)
Cargando…
23 Responses to Primeras impresiones después de trabajar a fondo con Prestashop 1.5
  1. Travis Responder

    La versión 1.5.2 también falla? Se supone que arreglaba muchos bugs… pues menuda faena, la verdad.

    • jordiob Responder

      A mí me han fallado todas desde el inicio de la 1.5 (no la beta test, la de producción)

  2. Clara Responder

    La verdad es que yo no llevo tanto tiempo trabajando con Prestashop y tengo poco tiempo en el ecommerce, pero comparando las versiones de la 1.4 con la 1.5 me quedo sin duda con la última porque, aunque siga teniendo fallos, a nivel de marketing y conversiones está mucho más preparada. Ya no hace falta acudir a tantos módulos de terceros porque han incluído casi todo lo que, al menos para mí, es básico y que antes había que traer de otros lados. Es una faena lo de no poder usar módulos y plantillas hasta que se actualicen los autores, sí, pero el hecho de que la 1.5 sea mucho más amigable con el móvil para mí es ya un gran punto a favor. Además, por dentro se parece tremendamente a Magento, siendo más fácil e intuitivo de usar Prestashop, por supuesto. SUpongo que aún hay mayores mejoras, pero por cómo pinta, me quedo con la 1.5. Más tiempo perdía en las 1.4, yo al menos, que busco siempre módulos para maximizar conversiones… ¡Gracias por tus aportaciones!

    • jordiob Responder

      Hola Clara. A qué modulos te refieres?

  3. Albert Responder

    Hola,

    Pues yo que quería empezar ya mi tienda con la última versión… Donde puedo descargar v. 1.4.9? Imagino que, a pesar de ello sigue siendo recomendable comprar una plantilla ya preparada para v. 1.5.2, no?

    Salu2

  4. kamal Responder

    he trabajado con 1.4.7 y todo muy bien.ahora 1.5.2 no me aprece log ni carrito mal sunto

    • jordiob Responder

      Yo me quedaría con la 1.4.9, sin duda

  5. Jollos Responder

    trabajo con la 1.4.7, me recomiendas actualizar a la 1.4.9?

    • jordiob Responder

      Sí, pero no a la 1.5

  6. cr Responder

    Mucha prisa por sacar la versión 1.5.3 y con muchos errores. No habria costadado mucho por parte de prestashop haberse esperado en las oficinas arreglando bugs y errores en lugar de exponer al publico un software llenito de errores que está dando tantos dolores de cabeza. A pesar que es un software libre y costo 0, pero tantas prisas por publicarlo por que!!

    • jordiob Responder

      De hecho tenían prisa porque la 1.5.2 tenía más de 400 errores. Pero estamos de acuerdo en que podían haberle sacado más brillo 🙂

  7. di Responder

    Y ahora que ya esta la 1.5.4 hay mejora sustancial o aun siguen los problemas que comentas?

    • jordiob Responder

      Pues mira. Ya me han petado las dos primeras así que… up to you 🙁

  8. Rachu Responder

    Hola, Jordi. ¿Sigues pensando lo mismo, después de un mes desde el último comentario? ¿Sigues sin recomendar la 1.5.4? Otra cosa, y perdona que me aproveche: ¿qué módulo me recomendarías para trabajar con el Banco de Sabadell? Gracias, y enhorabuena por tu blog.

    • jordiob Responder

      Sí. La cantidad de problemas que ha dado 1.5 a nivel de meteduras de pata y de core… uf. Incontable!
      El módulo que te recomendaría es el propio del Sabadell que corre por ahí 🙂

  9. Rachu Responder

    Por aquí también piensan lo mismo que tu. Lo malo es encontrar plantillas “responsive” para 1.4!

    • jordiob Responder

      en leothemes tienes algunas 🙂

  10. Gerardo Responder

    Estoy haciendo un módulo de prestashop y al darle a instalar ha salido un error por la restricción de versiones que tenía mi módulo. Ahora prestashop sólo saca error 500 en la página de módulos. A reinstalar !

  11. Gerardo Responder

    Además me he encontrado una serie de cagadas a nivel de programación que dan un poco de pena:

    * Cagada #1
    if (!defined(‘_PS_VERSION_’))
    exit;
    This checks for the existence of a PrestaShop constant, and if it does not exist, it stops the module from loading. The sole purpose of this is to prevent malicious visitors to load this file directly.
    * Cagada #2
    En el constructor de un módulo: Esto debería abstraerse y no estar en todas las putas clases.
    $this->confirmUninstall = $this->l(‘Are you sure you want to uninstall?’);
    * Cagada #3
    En la clase de un módulo: ¿No saben escribir código o qué?
    if (parent::install() == false)
    return false;
    return true;
    * Cagada #4
    Por qué bendito motivo está el token de sesión en la url?

    http://localhost/admin7387/index.php?controller=AdminLogin&token=aebe33033b76f8053b2d6b7b3499dd28&redirect=AdminHome

    • jordiob Responder

      Buenooooo! Y no has visto mucho todavía. Por eso sacan la 1.4.11

  12. Jorge Responder

    Creí que era el único que pensaba así.

    http://malditoprestashop.blogspot.com.es/

Deja un comentario

Your email address will not be published. Please enter your name, email and a comment.